buildroot/package/libspatialindex/0002-CMakeLists.txt-fix-CMAKE_BUILD_TYPE.patch
Fabrice Fontaine fed168f72f package/libspatialindex: fix build with microblaze
Add an upstream patch so the microblaze workaround for gcc bug 68485
won't get ignored

Fixes:
 - http://autobuild.buildroot.org/results/e4ad8fdeafce9d4a07d5554d98dfcb2fa5c05568

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-04-28 07:42:57 +02:00

31 lines
1.1 KiB
Diff

From 26d417b9f981cf9a6df42d89fd297539b96180cb Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Fri, 24 Apr 2020 18:03:31 +0200
Subject: [PATCH] CMakeLists.txt: fix CMAKE_BUILD_TYPE (#188)
The user is unable to override CMAKE_BUILD_TYPE since version 1.9.1 and
https://github.com/libspatialindex/libspatialindex/commit/e3bcccf38d9f100b59ccf29f7e1cfa174969decd
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Retrieved from:
https://github.com/libspatialindex/libspatialindex/commit/26d417b9f981cf9a6df42d89fd297539b96180cb]
---
CMakeLists.txt | 2 ++
1 file changed, 2 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 191ac72..84676a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,8 +93,10 @@ INCLUDE (CheckIncludeFiles)
# note we default to RelWithDebInfo mode
if(NOT MSVC_IDE)
+ if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE RelWithDebInfo CACHE STRING
"Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel" FORCE)
+ endif()
message(STATUS "Setting libspatialindex build type - ${CMAKE_BUILD_TYPE}")
endif()