buildroot/package/mediastreamer/0002-Use-AV_INPUT_BUFFER_PADDING_SIZE-to-determine-paddin.patch
Fabrice Fontaine 8f5562ed7c package/mediastreamer: bump to version 4.3.1
- Drop first patch (already in version)
- Update second patch
- License is GPL-3.0+ since version 4.3.0 and
  85094197cf
- Switch to cmake-package and so drop third patch as autotools is not
  updated anymore (and fails to build due to missing po/Makefile.in.in)
- Add a mandatory dependency to mbedtls (to enable crypto support in
  bctoolbox)
- Add bcg729, jpegturbo, libgsm, libpcap, libsrtp and zxing-cpp optional
  dependencies
- Add a dependency on dynamic library as no pkg-config calls are done in
  cmake (static build with ffmepg and opus will fail for example)
- Drop libupnp optional dependency (not available anymore)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-03-09 21:22:39 +01:00

45 lines
1.5 KiB
Diff

From 84b1919124884232e0fa30b30458470db27c73fc Mon Sep 17 00:00:00 2001
From: James Cowgill <jcowgill@debian.org>
Date: Sat, 18 Aug 2018 12:56:38 +0200
Subject: [PATCH] Use AV_INPUT_BUFFER_PADDING_SIZE to determine padding
size
Hardcoding the value for FF_INPUT_BUFFER_PADDING_SIZE is not safe
because upstream FFmpeg might change it (as they did in FFmpeg 4.0).
Instead, use FFmpeg's AV_INPUT_BUFFER_PADDING_SIZE if available and
only hardcode a value if FFmpeg is disabled (in which case the value
doesn't particularly matter anyway). For compatibility with older
FFmpeg versions, define AV_INPUT_BUFFER_PADDING_SIZE if hasn't been
defined yet.
Downloaded from
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=901735
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Fabrice: updated for 4.3.1]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
src/utils/ffmpeg-priv.h | 4 ++++
src/videofilters/nowebcam.c | 4 ++--
2 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/src/utils/ffmpeg-priv.h b/src/utils/ffmpeg-priv.h
index c0745a9a..d59ea0e1 100644
--- a/src/utils/ffmpeg-priv.h
+++ b/src/utils/ffmpeg-priv.h
@@ -102,6 +102,10 @@ static inline int avcodec_decode_video2(AVCodecContext *avctx, AVFrame *picture,
#endif
#endif
+#ifndef AV_INPUT_BUFFER_PADDING_SIZE
+#define AV_INPUT_BUFFER_PADDING_SIZE FF_INPUT_BUFFER_PADDING_SIZE
+#endif
+
#ifndef HAVE_FUN_avcodec_encode_video2
int avcodec_encode_video2 (AVCodecContext *avctx, AVPacket *avpkt, const AVFrame *frame, int *got_packet_ptr);
#endif
--
2.18.0