buildroot/package/rpm/0005-Really-disable-OpenMP-if-too-old.patch
Fabrice Fontaine 81b462a405 package/rpm: don't set openmp
Don't set openmp to fix a build failure with codesourcery toolchain that
doesn't have OpenMP >= 4.5 indeed upstream doesn't want to remove the
build failure if the user provides --enable-openmp and OpenMP is < 4.5:
https://github.com/rpm-software-management/rpm/pull/1433

Fixes:
 - http://autobuild.buildroot.org/results/05dd945d24e8684aad6a2343ba7f6f8a7cea8349

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2021-01-02 17:20:59 +01:00

27 lines
817 B
Diff

From 662a367f427d653c6b8fbc7fbd1ace5ba120a25f Mon Sep 17 00:00:00 2001
From: Michal Domonkos <mdomonko@redhat.com>
Date: Thu, 3 Dec 2020 15:11:57 +0100
Subject: [PATCH] Really disable OpenMP if too old
Fix up for commit 6a780f1.
[Retrieved from:
https://github.com/rpm-software-management/rpm/pull/1455]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index c853cd9af..beb65ff8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -187,6 +187,7 @@ AS_IF([test "x$ac_cv_prog_c_openmp" != x &&
AC_DEFINE(ENABLE_OPENMP, 1, [Enable multithreading support?])
],
[AC_MSG_RESULT([no])
+ OPENMP_CFLAGS=
if test "$enable_openmp" = "yes"; then
AC_MSG_ERROR([OpenMP too old])
fi