buildroot/package/suricata/0002-configure.ac-allow-the-user-to-override-RUST_TARGET.patch
Fabrice Fontaine f66774568d package/suricata: bump to version 6.0.0
- Refresh first patch
- Drop second patch, not needed since
  5c725d5050
- Drop BR2_PACKAGE_GEOIP dependency as suricata switched to GeoIP2, see
  a291209e47
- jansson is now a mandatory dependency, see
  e49c40428e
- rustc is now a mandatory dependency, see
  75429bbe3e

EOL date of 4.1 branch is December 31st, 2020.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-10-25 10:48:13 +01:00

36 lines
1.1 KiB
Diff

From 7ab4d5eb55e1d3900390b76e5f46e80e22d4e80e Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sat, 10 Oct 2020 21:34:21 +0200
Subject: [PATCH] configure.ac: allow the user to override RUST_TARGET
When cross-compiling, RUST_TARGET is not always equal to host_triplet
(e.g. buildroot) so allow the user to override this default value
through RUST_TARGET environment variable
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 32c230209..7d7c9373f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2489,7 +2489,12 @@ fi
have_rust_vendor="no"
if test "x$cross_compiling" = "xyes"; then
- RUST_SURICATA_LIB_XC_DIR="${host_alias}/"
+ if test "x$RUST_TARGET" != "x"; then
+ RUST_SURICATA_LIB_XC_DIR="$RUST_TARGET/"
+ AC_SUBST([RUST_TARGET],["--target $RUST_TARGET"])
+ else
+ RUST_SURICATA_LIB_XC_DIR="${host_alias}/"
+ fi
else
if test "x$CARGO_BUILD_TARGET" = "x"; then
RUST_SURICATA_LIB_XC_DIR=
--
2.28.0