buildroot/package/aumix/0001-fix-incorrect-makefile-am.patch
Bernd Kuhls 6348fcec36 package/aumix: bump version to 2.9.1
- rebased patch 0001
- added AUMIX_GETTEXTIZE = YES to solve
  *** error: gettext infrastructure mismatch: using a Makefile.in.in
  from gettext version 0.17 but the autoconf macros are from gettext
  version 0.19

Fixes
http://autobuild.buildroot.net/results/c8c/c8c7f9a799d1af507a6edd5e02b0bbc8b7b5d068/
http://autobuild.buildroot.net/results/67e/67e6d29e6d6f8d4967a74ec70a754a5b24afc0ce/
and others

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-01-26 22:07:41 +01:00

29 lines
1 KiB
Diff

Aumix's src/Makefile.am incorrect adds @includedir@ to the list of
include paths and @libdir@ to the list of libraries paths. This is
incorrect, as @includedir@ and @libdir@ are respectively /usr/include
and /usr/lib, even in cross-compilation mode.
At the same time, use AM_CFLAGS instead of CFLAGS, as is done on the
similar patch found in OpenEmbedded.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
src/Makefile.am | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
Index: aumix-2.8/src/Makefile.am
===================================================================
--- aumix-2.8.orig/src/Makefile.am
+++ aumix-2.8/src/Makefile.am
@@ -9,9 +9,8 @@
mouse.c common.h curses.h gpm-xterm.h gtk.h interactive.h \
mouse.h play.xpm record.xpm
localedir = $(datadir)/locale
-INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\" -I@includedir@
+INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\"
AM_CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ @GTK_CFLAGS@
-LDADD = -L@libdir@
LIBS = @LIBS@ @GTK_LIBS@ @LIBINTL@
DEFS = @DEFS@