buildroot/package/caps/0001-Fix-stdint-types-with-musl.patch
Martin Bark 04e272ba81 package/caps: new package
CAPS is a collection of audio plugins comprising virtual guitar
amplification and a small range of basic classic effects, signal
processors and generators of often elementary and occasionally
exotic nature.

The plugins aim to satisfy the highest demands in sound quality
with maximal computational efficiency and zero latency.

Note, that the original patch [1] dates back in 2014.

[1] https://patchwork.ozlabs.org/patch/376822/

CC: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
[Thomas:
 - drop patch 0001, use improved logic in .mk file instead
 - add dependency on !BR2_STATIC_LIBS]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-10-16 23:44:40 +02:00

55 lines
1.4 KiB
Diff

From 626e60a82120961ccee117dfcb5c28f72f8a26e5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
Date: Wed, 28 Aug 2019 11:25:49 +0200
Subject: [PATCH] Fix stdint types with musl
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Fetched from:
https://github.com/dsacre/meta-lad/blob/master/recipes-multimedia/lv2/caps-lv2/fix-stdint-types-with-musl.patch
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
basics.h | 17 +++++++++--------
1 file changed, 9 insertions(+), 8 deletions(-)
diff --git a/basics.h b/basics.h
index 643d96e..34e5f63 100644
--- a/basics.h
+++ b/basics.h
@@ -39,6 +39,7 @@
#define _ISOC9X_SOURCE 1
#include <stdlib.h>
+#include <stdint.h>
#include <string.h>
#include <math.h>
@@ -49,14 +50,14 @@
#include "ladspa.h"
-typedef __int8_t int8;
-typedef __uint8_t uint8;
-typedef __int16_t int16;
-typedef __uint16_t uint16;
-typedef __int32_t int32;
-typedef __uint32_t uint32;
-typedef __int64_t int64;
-typedef __uint64_t uint64;
+typedef int8_t int8;
+typedef uint8_t uint8;
+typedef int16_t int16;
+typedef uint16_t uint16;
+typedef int32_t int32;
+typedef uint32_t uint32;
+typedef int64_t int64;
+typedef uint64_t uint64;
#define MIN_GAIN 1e-6 /* -120 dB */
/* smallest non-denormal 32 bit IEEE float is 1.18e-38 */
--
2.22.0