buildroot/package/dillo/0003-Fix-openssl-detection.patch
Peter Seiderer 62ad96c057 package/dillo: fix openssl support
Add two patches to fix openssl support:

 - 0003-Fix-openssl-detection.patch (suggested by Jonathan Kimmitt)
 - 0004-Support-OpenSSL-1.1.0.patch (taken from upstream)

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-01-10 22:32:02 +01:00

30 lines
845 B
Diff

From 96dde9dedf806256cdc6cbf5cacbd5c8d74e6288 Mon Sep 17 00:00:00 2001
From: Jonathan Kimmitt <jrrk2@cam.ac.uk>
Date: Thu, 9 Jan 2020 22:01:42 +0100
Subject: [PATCH] Fix openssl detection
SSL_library_init is now a define, use OPENSSL_init_ssl instead.
Signed-off-by: Jonathan Kimmitt <jrrk2@cam.ac.uk>
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 66b5e9f..206fd53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -276,7 +276,7 @@ if test "x$enable_ssl" = "xyes"; then
if test "x$ssl_ok" = "xyes"; then
old_libs="$LIBS"
- AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
+ AC_CHECK_LIB(ssl, OPENSSL_init_ssl, ssl_ok=yes, ssl_ok=no, -lcrypto)
LIBS="$old_libs"
fi
--
2.24.1