buildroot/package/gqrx/0004-link_against_gr-audio_library.patch
Gwenhael Goavec-Merou 0af0d5bdb6 package/gqrx: backport/adapt patch to suppport Gnuradio 3.8
Gnuradio 3.8 has broken some APIs, and the current gqrx release does
not support these API changes.

So we add compatibility backport patches from the following
pull-request: https://github.com/csete/gqrx/pull/705

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-02-03 23:43:33 +01:00

23 lines
698 B
Diff

From 89a6ce21aaa2c05e906100d7e5efc70ca41e880b Mon Sep 17 00:00:00 2001
From: Alexander Fasching <fasching.a91@gmail.com>
Date: Mon, 28 Oct 2019 09:40:25 +0100
Subject: [PATCH] Link against gr-audio library
Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
src/CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 88c54046..7d73f742 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -76,6 +76,7 @@ if(NOT Gnuradio_VERSION VERSION_LESS "3.
gnuradio::gnuradio-blocks
gnuradio::gnuradio-digital
gnuradio::gnuradio-filter
+ gnuradio::gnuradio-audio
)
endif()