buildroot/package/grpc/0001-target-build-using-host-plugin.patch
Adam Duskett e0e54afd0c package/grpc: bump to version 1.25.0
Other changes:

 - Remove upstream patch 0004-Fix-gettid-naming-conflict.patch
 - Remove upstream patch 0005-Rename-gettid-functions.patch
 - Add a check for BR2_TOOLCHAIN_GCC_AT_LEAST_5 in grpc.mk. If the
   selected toolchain is not at least version 5 or higher and the
   optimization level is -Os, set the GRPC_CFLAGS and GRPC_CXXFLAGS
   optimizations to -O2. This check prevents the following error:

   error: failure memory model cannot be stronger than success memory model for '__atomic_compare_exchange'

Tested with test-pkg, all tests passed:
            br-arm-full [1/6]: OK
 br-arm-cortex-a9-glibc [2/6]: OK
  br-arm-cortex-m4-full [3/6]: SKIPPED
         br-x86-64-musl [4/6]: OK
     br-arm-full-static [5/6]: SKIPPED

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-12-08 15:39:57 +01:00

53 lines
1.4 KiB
Diff

From aa18148e392ef28275a182db34397ccb66fb4617 Mon Sep 17 00:00:00 2001
From: Robert Rose <robertroyrose@gmail.com>
Date: Wed, 28 Nov 2018 09:41:52 -0800
Subject: [PATCH] CMakeLists.txt: allow passing a pre-existing grpc_cpp_plugin
The grpc_cpp_plugin is meant to be executed during the build process
of grpc. As such, in cross-compilation contexts, this program needs to
be built for the host machine and not the target machine. In order to
allow this, this commit adds an option gRPC_NATIVE_CPP_PLUGIN that can
be passed on the command line, with the path to an existing
grpc_cpp_plugin binary. If not passed, grpc_cpp_plugin is built as
usual.
Signed-off-by: Robert Rose <robertroyrose@gmail.com>
---
CMakeLists.txt | 13 +++++++++++++
1 file changed, 13 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc76cf5..7a22b08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13420,6 +13420,18 @@ target_link_libraries(grpc_cli
endif (gRPC_BUILD_TESTS)
if (gRPC_BUILD_CODEGEN)
+if (gRPC_NATIVE_CPP_PLUGIN)
+
+add_executable(grpc_cpp_plugin
+ IMPORTED
+)
+
+set_property(TARGET grpc_cpp_plugin
+ PROPERTY IMPORTED_LOCATION ${gRPC_NATIVE_CPP_PLUGIN}
+)
+
+else()
+
add_executable(grpc_cpp_plugin
src/compiler/cpp_plugin.cc
)
@@ -13457,6 +13469,7 @@ if (gRPC_INSTALL)
ARCHIVE DESTINATION ${gRPC_INSTALL_LIBDIR}
)
endif()
+endif()
endif (gRPC_BUILD_CODEGEN)
if (gRPC_BUILD_CODEGEN)
--
2.20.0.rc0.387.gc7a69e6b6c-goog