buildroot/package/luajit/0001-no-bin-symlink.patch
Francois Perrad 2ca0accc21 package/luajit: switch to moonjit fork
This fork is based on LuaJIT 2.1.0-beta3 which supports ARM64.

The license file is changed with the copyright from the Moonjit
developers, and an additional copy of the MIT license. Therefore the
license terms are still the same: MIT.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: add details about why the hash of the license file changes]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-12-06 23:47:27 +01:00

27 lines
914 B
Diff

Do not use a symlink for the binary, simply name it luajit
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -44,8 +44,7 @@
INSTALL_MAN= $(INSTALL_SHARE)/man/man1
INSTALL_PKGCONFIG= $(INSTALL_LIB)/pkgconfig
-INSTALL_TNAME= luajit-$(VERSION)
-INSTALL_TSYMNAME= luajit
+INSTALL_TNAME= luajit
INSTALL_ANAME= libluajit-$(ABIVER).a
INSTALL_SOSHORT1= libluajit-$(ABIVER).so
INSTALL_SOSHORT2= libluajit-$(ABIVER).so.$(MAJVER)
@@ -60,7 +59,6 @@
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT1)
INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT2)
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
-INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
INSTALL_DIRS= $(INSTALL_BIN) $(INSTALL_LIB) $(INSTALL_INC) $(INSTALL_MAN) \