buildroot/package/ti-sgx-um/0001-Makefile-do-not-install-init-script.patch
Lothar Felten c38b5566fe package/ti-sgx-{km, um, demos}: bump to latest TI version
ti-sgx-um

- Bump the version that matches TI SDK 06.00.00.07 plus one pull request
  that updates the EGL/GLES headers required to build qt5base.
- Rewrite the init script, following the current template and using the
  pvrsrvctl command (pvrsrvinit does not exit anymore).
- Remove powervr.ini, no longer used in the TI SDK.
- Select and add a dependency on wayland, or else packages that link to
  libEGL (e.g. cairo) fail to link due to a missing libwayland-server.
- Update license file name.

ti-sgx-demos

- Bump the version that matches TI SDK 06.00.00.07 plus one pull request
  (matching ti-sgx-um).

ti-sgx-km

- Bump the version that matches TI SDK 06.00.00.07.
- Remove stray empty lines.
- Fix license file path.

All packages

- Use HTTP to clone Git repositories.
- Update URL in Config.in files, pointing to cgit and using HTTPS.
- Add hashes for all license files.

The buildroot package only supports the target am335x. Support for other
boards can be added by adding menu entries to select the correct target
product.

Signed-off-by: Lothar Felten <lothar.felten@gmail.com>
Signed-off-by: Carlos Santos <unixmania@gmail.com>
[Thomas:
 - add missing depends on BR2_PACKAGE_HAS_UDEV from Config.in,
   inherited from ti-sgx-libgbm]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-12-30 14:46:41 +01:00

40 lines
1 KiB
Diff

From afb92e4b1cd05388f519868215d0e8a4672ebb0e Mon Sep 17 00:00:00 2001
From: Carlos Santos <unixmania@gmail.com>
Date: Sun, 10 Nov 2019 22:44:44 -0300
Subject: [PATCH] Makefile: do not install init script
Use a custom one, made for Buildroot, instead.
Signed-off-by: Carlos Santos <unixmania@gmail.com>
---
Makefile | 3 ---
1 file changed, 3 deletions(-)
diff --git a/Makefile b/Makefile
index 649111a..19016f3 100755
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,6 @@ TARGET_PRODUCT ?= jacinto6evm
SRCDIR = ./targetfs/${TARGET_PRODUCT}
prefix = /usr
-etcdir = /etc
bindir = ${prefix}/bin
incdir = ${prefix}/include
libdir = ${prefix}/lib
@@ -11,11 +10,9 @@ libdir = ${prefix}/lib
all:
install:
- mkdir -p ${DESTDIR}${etcdir}
mkdir -p ${DESTDIR}${bindir}
mkdir -p ${DESTDIR}${incdir}
mkdir -p ${DESTDIR}${libdir}
- cp -ar ${SRCDIR}/etc/* ${DESTDIR}${etcdir}
cp -ar ${SRCDIR}/bin/* ${DESTDIR}${bindir}
cp -ar ${SRCDIR}/include/* ${DESTDIR}${incdir}
cp -ar ${SRCDIR}/lib/* ${DESTDIR}${libdir}
--
2.18.1