buildroot/package/vlc/0002-lua-Define-LUA_COMPAT_APIINTCASTS-for-Lua-5.3.0-comp.patch
Bernd Kuhls 7dd64181d0 package/vlc: bump version to 3.0.3
vlc depends on gcc-4.9+:
https://mailman.videolan.org/pipermail/vlc-devel/2016-September/109452.html

Added fix for stack-protector detection.

Disabled all new optional dependencies for now, subsequent patches will
enable dependencies with buildroot packages present.

Removed gles1 configure option after
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=6c4bb081844c51a9a1b1cdb44fc5f42e5a879327

Renamed mmal configure options after
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=bdb1d86acfb0d0068e57281b6fbfc52345960d29
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=1d2b56c68bbc3287e17f6140bdf8c8c3efe08fdc

Renamed avahi configure option after
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=55280fa62cb68b71767778c56250352b4840b69a

Removed directfb support after being dropped upstream:
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=8e1a0e876615da31321203090daa7c8699b6406d

Renamed matroska configure option after
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=156ceb73e2f46618a6cffb081e71e368a315ec3e

Replaced qt4 support with qt5:
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=1c221a77d92935866e897254c07e1d12a4b95ae0

Removed sdl support:
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=4b8a2755fe8c0e3e1e9c52483b22c26e24fd5527

Removed --enable-xcb in BR2_PACKAGE_XCB_UTIL_KEYSYMS block, it is
already present in the BR2_PACKAGE_LIBXCB block.

Rebased patches
- 0001-Disable-building-of-statically-linked-vlc-binary.patch
- 0007-Don-t-assume-strerror_l-is-available.patch
- 0009-x264-drop-148-build-support-and-fix-10bit-support.patch
  also renamed from 0013

Removed patches
- 0002-configure.ac-add-check-for-libgcrypt-config-program.patch
  not needed anymore after upstream commit
  http://git.videolan.org/?p=vlc.git;a=commitdiff;h=f94ac7241f33b6896a8e12ae4e3e43d9fd7fb6cc
- 0004-Drop-error-implicit-function-declaration-compile-fla.patch
- 0006-Don-t-assume-X11-is-available-when-Qt5-is-used.patch
  removed, qt4 is not supported anymore
- 0008-fix-fallback-code-and-add-required-realtime-library-.patch
- 0009-Changes-for-ffmpeg-3.0.patch
- 0010-Fix-build-when-using-C99-and-C-11.patch
- 0011-compat-fix-static_assert.patch
- 0012-Fix-build-with-libupnp-above-1.6.23.patch

New patches
- 0002-lua-Define-LUA_COMPAT_APIINTCASTS-for-Lua-5.3.0-comp.patch to fix lua-5.3 support
- 0004-qt-fix-build-against-Qt-5.11.patch
- 0006-Fix-build-error-using-uClibc-by-adding-sys-types.h.patch
- 0008-posix-remove-ancient-run-time-fallback-to-real-time-.patch
- 0010-Add-support-for-freerdp2.patch
  fixes support for freerdp >= 2.0

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: use Git formatted patches.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2018-08-16 12:34:10 +02:00

42 lines
1.3 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From 00135e21bec84a2fe5920d02fa0982ceb9f89a35 Mon Sep 17 00:00:00 2001
From: Vinson Lee <vlee@freedesktop.org>
Date: Thu, 5 Feb 2015 14:48:53 -0800
Subject: [PATCH] lua: Define LUA_COMPAT_APIINTCASTS for Lua >= 5.3.0
compatibility.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
In Lua 5.3.0, luaL_checkint was deprecated.
This patch fixes this build error with Lua 5.3.0.
lua/demux.c: In function vlclua_demux_peek:
lua/demux.c:55:5: error: implicit declaration of function luaL_checkint [-Werror=implicit-function-declaration]
int n = luaL_checkint( L, 1 );
^
Signed-off-by: Vinson Lee <vlee@freedesktop.org>
Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
[Backport upstream commit 41caaa08cde60c4fec4bf2e5f9610e2a1b9e6a23]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
modules/lua/vlc.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/modules/lua/vlc.h b/modules/lua/vlc.h
index 71f381d334..b46b5f67a1 100644
--- a/modules/lua/vlc.h
+++ b/modules/lua/vlc.h
@@ -38,6 +38,7 @@
#include <vlc_stream.h>
#include <vlc_demux.h>
+#define LUA_COMPAT_APIINTCASTS
#define LUA_COMPAT_MODULE
#include <lua.h> /* Low level lua C API */
#include <lauxlib.h> /* Higher level C API */
--
2.14.4