buildroot/package/efivar/0001-Allow-build-with-uClibc.patch
Peter Korsgaard bb7a698001 efivar: bump version
Drop 0001-Use-z-muldefs-to-avoid-the-multiple-definitions-bug-.patch and
0003-Remove-some-extra-const-that-gcc-complains-about.patch as they are now
upstream.

The upstream repo moved to the 'rhboot' github project, so adjust upstream
URL in .mk and help text to match.

Drop dependency on !musl as it is now support since e04281e60cf0d
(makeguids: Ensure compatibility with other libcs).

Drop BINTARGETS workaround as this is fixed since 6c674283697 (Don't build
static by default).

Drop popt dependency as it is no longer needed since 1aec5e7891 (Replace
popt usage with getopt_long in efivar.c).

While we are at it, also add a hash for the license file.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2018-03-23 16:29:22 +01:00

39 lines
885 B
Diff

From 2255601757a8a58baddad2d37d0bcc6b003a3732 Mon Sep 17 00:00:00 2001
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Date: Fri, 25 Nov 2016 19:42:27 +0200
Subject: [PATCH] Allow build with uClibc
Basically this replaces type definitions in <uchar.h>.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
src/export.c | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/src/export.c b/src/export.c
index 7f2d4dd..72c02d1 100644
--- a/src/export.c
+++ b/src/export.c
@@ -21,11 +21,17 @@
#include <inttypes.h>
#include <stdint.h>
#include <stdlib.h>
-#include <uchar.h>
#include <efivar/efivar.h>
#include "lib.h"
+#ifdef __UCLIBC__
+typedef int_least16_t char16_t;
+typedef int_least32_t char32_t;
+#else
+#include <uchar.h>
+#endif
+
#define EFIVAR_MAGIC 0xf3df1597
#define ATTRS_UNSET 0xa5a5a5a5a5a5a5a5
--
2.10.2