buildroot/package/exim/0006-remove-libnsl.patch
Romain Naour a759d5e696 package/exim: remove libnsl linking
glibc now considers its built-in libnsl as being obsolete, and requires
passing --enable-obsolete-libnsl to have it built and installed. libnsl
is now provided as a separate project [1], but it isn't packaged yet in
Buildroot.

In preparation for dropping --enable-obsolete-libnsl from the glibc
package, this commit ensures that exim doesn't use libnsl. It was
already the case for uclibc and musl toolchains, so this commit simply
extends that to make sure libnsl is also not used with glibc toolchains.

Only Exim's nis.so and nisplus.so lookup modules require libnsl,
but they are not build by default. So we can safely remove -lnsl
from the Makefile-Linux. If someone want these modules, a new libnsl
package must be added first to provide nsl library.

Since we remove -lnsl unconditionally, use a patch instead of a sed command.

[1] https://github.com/thkukuk/libnsl.git
[2] https://fedoraproject.org/wiki/Changes/NISIPv6

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Baruch Siach <baruch@tkos.co.il>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2018-05-19 21:38:00 +02:00

38 lines
1 KiB
Diff

From b722f8fc01f6b1d71c98c0c66f759935b0dac136 Mon Sep 17 00:00:00 2001
From: Romain Naour <romain.naour@gmail.com>
Date: Sat, 19 May 2018 20:36:41 +0200
Subject: [PATCH] remove libnsl
glibc now considers its built-in libnsl as being obsolete, and requires
passing --enable-obsolete-libnsl to have it built and installed. libnsl
is now provided as a separate project [1], but it isn't packaged yet in
Buildroot.
Exim's nis.so and nisplus.so lookup modules require libnsl,
but they are not build by default. So we can safely remove -lnsl
from the Makefile-Linux.
[1] https://github.com/thkukuk/libnsl.git
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
OS/Makefile-Linux | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/OS/Makefile-Linux b/OS/Makefile-Linux
index 990f884..ea5644b 100644
--- a/OS/Makefile-Linux
+++ b/OS/Makefile-Linux
@@ -19,7 +19,7 @@ CFLAGS_DYNAMIC ?= -shared -rdynamic
DBMLIB = -ldb
USE_DB = yes
-LIBS = -lnsl -lcrypt -lm
+LIBS = -lcrypt -lm
LIBRESOLV = -lresolv
X11=/usr/X11R6
--
2.14.3