buildroot/package/freeswitch/0001-Fix-cross-compiling-libvpx.patch
Peter Seiderer 1e4b7ea3f6 freeswitch: bump version to 1.8.1
Enables openssl-1.1.x compatible compile.

- add tiff dependency (bundled tiff source is gone)
- rebase (and git format) 0001-libvpx-cross.patch patch
- update libs/srtp/LICENSE file hash (updated copyright year)

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
[Bernd:
- bumped to 1.8.1
- rebased patch 0001 to the tarball release
- added hashes for libvpx & libyuv license files]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2018-09-08 15:10:13 +02:00

30 lines
1.7 KiB
Diff

Fix cross-compiling libvpx
Freeswitch since version 1.6.7 only uses an in-tree-version of libvpx:
https://freeswitch.org/fisheye/changelog/freeswitch?cs=febe0f8dacea2d2a31902b3dc469be757f8c3c4d
It is not possible to use an external version of libvpx anymore.
Unfortunately the freeswitch build system has no support for cross-
compiling libvpx so we need to patch Makefile to pass CROSS from
package/freeswitch/freeswitch.mk and add target=generic-gnu as
configure parameter:
https://freeswitch.org/stash/projects/FS/repos/freeswitch/browse/libs/libvpx/README#110
And yes, autoreconf is also broken, so we patch Makefile.in instead
of Makefile.am.
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
diff -uNr freeswitch-1.6.7.org/Makefile.in freeswitch-1.6.7/Makefile.in
--- freeswitch-1.6.7.org/Makefile.in 2016-04-01 18:09:54.000000000 +0200
+++ freeswitch-1.6.7/Makefile.in 2016-04-22 20:11:37.938961730 +0200
@@ -4025,7 +4025,7 @@
cd libs/libzrtp && $(MAKE)
libs/libvpx/Makefile:
- cd libs/libvpx && CC="$(CC)" CXX="$(CXX)" CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure --enable-pic --disable-docs --disable-examples --disable-install-bins --disable-install-srcs --disable-unit-tests --size-limit=16384x16384 --extra-cflags="$(VISIBILITY_FLAG)"
+ cd libs/libvpx && CROSS=$(CROSS) CC="$(CC)" CXX="$(CXX)" CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure --target=generic-gnu --enable-pic --disable-docs --disable-examples --disable-install-bins --disable-install-srcs --disable-unit-tests --size-limit=16384x16384 --extra-cflags="$(VISIBILITY_FLAG)"
libs/libvpx/libvpx.a: libs/libvpx/Makefile
@cd libs/libvpx && $(MAKE)