buildroot/package/iperf3/0001-disable-profiling.patch
Gustavo Zacarias 6cf9c2b830 iperf3: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-12-21 20:04:50 +01:00

21 lines
897 B
Diff

This should be an option, but it's not.
Don't force profiled builds, it breaks on many toolchains.
Patch Makefile.in to avoid AUTORECONFing since it needs dummy files
that are missing to succeed (ChangeLog, COPYING, NEWS, README) and it's
simple enough so avoid pulling in dependencies and delays.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura iperf-3.0.10.orig/src/Makefile.in iperf-3.0.10/src/Makefile.in
--- iperf-3.0.10.orig/src/Makefile.in 2014-12-17 07:30:46.878310789 -0300
+++ iperf-3.0.10/src/Makefile.in 2014-12-17 07:33:41.879356643 -0300
@@ -82,7 +82,7 @@
host_triplet = @host@
bin_PROGRAMS = iperf3$(EXEEXT)
noinst_PROGRAMS = t_timer$(EXEEXT) t_units$(EXEEXT) t_uuid$(EXEEXT) \
- iperf3_profile$(EXEEXT)
+ iperf3$(EXEEXT)
TESTS = t_timer$(EXEEXT) t_units$(EXEEXT) t_uuid$(EXEEXT)
subdir = src
DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \