buildroot/package/sdl2_ttf/0001-fix-opengl-detection.patch
Yann E. MORIN cd869112a4 package/sdl2_ttf: fix detection of OpenGL
Backport a opatch from upstream to preoperly detect OpenGL, add patch to
fix autoreconf.

Fixes:
    http://autobuild.buildroot.org/results/be9/be9d9d0d75dca62d9edb28c1e4d81f7f33b30ea8/
    http://autobuild.buildroot.org/results/db8/db87a00a7cd1f8d1627fa4a39a0f67e9328b2b0f/
    http://autobuild.buildroot.org/results/f45/f45a9588090c296c9c5ece2cbc71f8bb64bebf73/
    http://autobuild.buildroot.org/results/9cb/9cb669ab6760420421e3c907462b69fe36c46601/
    and many others...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Thompson <peter.macleod.thompson@gmail.com>
Cc: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2017-01-28 23:31:34 +13:00

38 lines
1,002 B
Diff

# HG changeset patch
# User Sam Lantinga <slouken@libsdl.org>
# Date 1485568474 28800
# Node ID 3b93536d291a34183592fd29ef1df9cf1416ac09
# Parent 184c34c673d479477d34194e3c0b1abe7ca5d828
Make sure we can link with OpenGL libraries in the OpenGL configure test
[yann.morin.1998@free.fr:
- backported from upstream
- drop the configure hunk for autoreconf
]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
diff -r 184c34c673d4 -r 3b93536d291a configure.in
--- a/configure.in Sun Jan 01 18:46:38 2017 -0800
+++ b/configure.in Fri Jan 27 17:54:34 2017 -0800
@@ -164,14 +164,17 @@
esac
AC_MSG_CHECKING(for OpenGL support)
have_opengl=no
-AC_TRY_COMPILE([
+save_LIBS="$LIBS"
+LIBS="$LIBS $SYS_GL_LIBS"
+AC_TRY_LINK([
#include "SDL_opengl.h"
],[
- GLuint texture;
+ glOrtho( -2.0, 2.0, -2.0, 2.0, -20.0, 20.0 );
],[
have_opengl=yes
])
AC_MSG_RESULT($have_opengl)
+LIBS="$save_LIBS"
if test x$have_opengl = xyes; then
CFLAGS="$CFLAGS -DHAVE_OPENGL"
GL_LIBS="$SYS_GL_LIBS"