buildroot/package/zbar/0001-Fix-autoreconf-by-reducing-the-warning-error-checkin.patch
Volkov Viacheslav 3da4704bb2 zbar: new package
[Thomas:
 - replace patch 0001 fixing autoreconf by a simpler patch that simply
   drops the -Wall and -Werror flags passed to automake.
 - reformat the two patches using Git
 - drop the "uclibc || glibc" dependency inherited from libv4l, since
   libv4l has now been fixed to build on musl.
 - drop the hook work arounding a build issue around man pages, and
   replace by a patch that completely disables the build/installation
   of documentation.
 - change license to LGPLv2.1+, as noted in the COPYING file.
 - drop --enable-shared=yes, since it is already passed by the
   autotools-package infrastructure]

Signed-off-by: Viacheslav Volkov <sv99@inbox.ru>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-12-20 12:45:39 +01:00

27 lines
901 B
Diff

From e593d6529cff515d94d80a24b5f3a953fd46004c Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Sat, 19 Dec 2015 18:56:36 +0100
Subject: [PATCH] Fix autoreconf by reducing the warning/error checking
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 256aedb..e0b6046 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ AC_PREREQ([2.61])
AC_INIT([zbar], [0.10], [spadix@users.sourceforge.net])
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(config)
-AM_INIT_AUTOMAKE([1.10 -Wall -Werror foreign subdir-objects std-options dist-bzip2])
+AM_INIT_AUTOMAKE([1.10 foreign subdir-objects std-options dist-bzip2])
AC_CONFIG_HEADERS([include/config.h])
AC_CONFIG_SRCDIR(zbar/scanner.c)
LT_PREREQ([2.2])
--
2.6.4