buildroot/package/open-lldp/0002-Makefile.am-disable-Werror.patch
Fabrice Fontaine 27515371fa package/open-lldp: bump version to b71bfb87fefb31c4b1a6a7ae351791c90966c3a8
- Switch site to github
- Remove first patch (already in version)
- Update second patch
- Update indentation of hash file (two spaces)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-04-12 12:26:13 +02:00

39 lines
1.3 KiB
Diff

From c350f263136801fd54d42322a07a3b5ad2181dd9 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Thu, 18 Jan 2018 09:29:32 +0100
Subject: [PATCH] Makefile.am: disable -Werror
Due to additional warnings in recent gcc versions and the use of
-Werror the build fails for reasons that are not that important. For
example:
clif.c:54:2: error: implicit declaration of function 'memset' [-Werror=implicit-function-declaration]
memset(clif, 0, sizeof(*clif));
or:
log.c:46:30: error: format '%ld' expects argument of type 'long int', but argument 5 has type '__suseconds_t {aka int}' [-Werror=format=]
printf("%02d:%02d:%02d.%06ld ",
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index 551d4c7..62a52a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,7 @@ ACLOCAL_AMFLAGS = -I m4
parse_cli.o: CFLAGS+=-U_FORTIFY_SOURCE -Wno-error
## system requires a shared libconfig
-AM_CFLAGS = -Wall -Werror -Wextra -Wformat=2 $(LIBCONFIG_CFLAGS) $(LIBNL_CFLAGS)
+AM_CFLAGS = -Wall -Wextra -Wformat=2 $(LIBCONFIG_CFLAGS) $(LIBNL_CFLAGS)
AM_LDFLAGS = $(LIBCONFIG_LIBS) $(LIBNL_LIBS) -lrt
## header files to be installed, for programs using the client interface to lldpad
--
2.14.3