buildroot/package/aufs-util/0002-no-check-ver.patch
Christian Stewart bdef0f00f9 aufs-util: new package
Signed-off-by: Christian Stewart <christian@paral.in>
[Atul:
 - Updated the default to empty.
 - Updated the license to GPLv2.
 - Used patches instead of SED commands.
 - CC and LD are replaced by TARGET_CC and TARGET_LD.]
Signed-off-by: Atul Singh <atul.singh.mandla@rockwellcollins.com>
[yann.morin.1998@free.fr:
  - drop the headers_install command
  - instead, instruct the kernel to install them
  - add patches 0002..0004
  - properly build the host tools
  - don't depend on the aufs extension, for kernel already patched
  - fix comment]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
[Thomas:
 - Remove the patch 0004-no-override-readdir64.patch, since it no longer
   applies to the latest version of aufs-util. Instead, add a post-patch
   hook that tweaks the Makefile to remove the problematic rdu64.o from
   the build process.
 - Use directly the kernel headers from the kernel source tree, rather
   than having to install them. This only requires a minor trick to
   define "__user" to empty.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-09-20 19:16:42 +02:00

25 lines
756 B
Diff

Makefile: do not check version
The aufs-util package tries to ensure that its version is compatible
with the one in the running kernel. However, this test is flawed: the
version string in the aufs4x branch for aufs-util is aufs3.x, so it does
not match the version in the kernel when it is aufs4.x.
Disengage this check, ion the assumption the user knows what he is
doing.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
diff --git a/Makefile b/Makefile
--- a/Makefile
+++ b/Makefile
@@ -62,7 +62,7 @@
$(foreach v, CPPFLAGS CFLAGS INSTALL Install ManDir LibUtilHdr, \
$(eval MAKE += ${v}="$${${v}}"))
-all: ver_test ${Man} ${Bin} ${Etc}
+all: ${Man} ${Bin} ${Etc}
${MAKE} -C libau $@
ln -sf ./libau/libau*.so .
$(call MakeFHSM, $@)