buildroot/package/cwiid/0001-wmdemo-fix-linking-by-adding-the-missing-lbluetooth-.patch
Bernd Kuhls b9ea113f69 package/cwiid: bump version
kodi needs CWIID_MESG_BALANCE
https://github.com/xbmc/xbmc/blob/Krypton/tools/EventClients/Clients/WiiRemote/CWIID_WiiRemote.cpp#L106

It was added after the last cwiid release, which took place 2009:
2174214bc2

Instead of adding another 20k-sized patch we switch to the upstream
github repo and bump to its HEAD commit, dating back to 2010.

By doing this we can remove two patches which were applied upstream:

0001-fix-link-options-for-as-needed-90.patch
6af6786165

0002-Update-for-BlueZ-changes.patch
c5dd7d4a9a

The remaining patches were renumbered.

This patch is needed for the upcoming Kodi version bump which also adds
optional cwiid support.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2017-03-01 22:19:16 +01:00

28 lines
735 B
Diff

From af6bffb5b8b71e99e0f9bbbd2cf1fbd695a643c2 Mon Sep 17 00:00:00 2001
From: Samuel Martin <s.martin49@gmail.com>
Date: Sat, 8 Dec 2012 13:32:40 +0100
Subject: [PATCH 1/2] wmdemo: fix linking by adding the missing -lbluetooth to
LDLIBS
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
wmdemo/Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/wmdemo/Makefile.in b/wmdemo/Makefile.in
index 56aed58..1eccc02 100644
--- a/wmdemo/Makefile.in
+++ b/wmdemo/Makefile.in
@@ -8,7 +8,7 @@ SOURCES = wmdemo.c
CFLAGS += -I@top_builddir@/libcwiid
LDFLAGS += -L@top_builddir@/libcwiid
-LDLIBS += -lcwiid
+LDLIBS += -lcwiid -lbluetooth
INST_DIR = @bindir@
include $(COMMON)/include/app.mak
--
1.8.5.2