buildroot/package/fbgrab/0001-fix-static-build.patch
Peter Korsgaard 298cd8eaa2 package/*: rename patches according to the new policy
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345)

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-02-03 14:52:56 +01:00

22 lines
649 B
Diff

Fix static build
fbgrab links against libpng, which depends on libm. For shared library
builds, there is nothing special to do about this, but for static
library builds, it is necessary to pass -lm when linking fbgrab.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@
all: fbgrab fbgrab.1.gz
fbgrab: fbgrab.c
- $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) $< -lpng -lz -o $@
+ $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) $< -lpng -lz -lm -o $@
fbgrab.1.gz: fbgrab.1.man
$(GZIP) $(GZIPFLAGS) $< > $@