buildroot/package/fcgiwrap/0001-use-LIBS-from-configure.patch
Thomas Claveirole 5ba276de2a fcgiwrap: new package
Add package fcgiwrap from https://nginx.localdomain.pl/wiki/FcgiWrap

fcgiwrap is a simple server for running CGI applications over
FastCGI. It hopes to provide clean CGI support to Nginx (and other web
servers that may need it).

Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-07-11 00:25:09 +02:00

23 lines
836 B
Diff

Makefile.in: Use LIBS from configure rather than specifying -lfcgi manually.
libfcgi needs libm and fcgiwrap does not use libtool or pkgconf to
detect libfcgi, so we need to add -lm explicitely when using static
libs. Buildroot does this by providing LIBS=-lm to configure when
needed. However fcgiwrap does not use Automake and its Makefile.in
ignores LIBS from configure. Fix it with this patch.
Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
diff -ur a/Makefile.in b/Makefile.in
--- a/Makefile.in 2013-02-03 14:25:17.000000000 +0100
+++ b/Makefile.in 2015-05-29 16:33:23.895280138 +0200
@@ -16,7 +16,7 @@
install -m 644 systemd/fcgiwrap.service $(DESTDIR)@systemdsystemunitdir@
endif
-LDLIBS = -lfcgi @systemd_LIBS@
+LDLIBS = @LIBS@ @systemd_LIBS@
CFLAGS = @AM_CFLAGS@
fcgiwrap: fcgiwrap.c