buildroot/package/irda-utils/0003-subdir.patch
Peter Korsgaard 298cd8eaa2 package/*: rename patches according to the new policy
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345)

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-02-03 14:52:56 +01:00

24 lines
627 B
Diff

written by Mike Frysinger
https://sourceforge.net/tracker/?func=detail&aid=3132051&group_id=5616&atid=305616
The top level makefile ignores build/install errors in subdirs which makes
packaging a pain to verify.
--- a/Makefile
+++ b/Makefile
@@ -31,11 +31,11 @@
CFLAGS= -O2 -W -Wall
all:
- @-(set -e ; for d in $(DIRS) ; do $(MAKE) $(MAKE_OUTPUT) -C $$d $@ ; done)
+ @(set -e ; for d in $(DIRS) ; do $(MAKE) $(MAKE_OUTPUT) -C $$d $@ ; done)
install:
- @-(set -e ; for d in $(DIRS) ; do $(MAKE) $(MAKE_OUTPUT) -C $$d $@ ; done)
+ @(set -e ; for d in $(DIRS) ; do $(MAKE) $(MAKE_OUTPUT) -C $$d $@ ; done)
clean: