buildroot/package/libfcgi/0003-link-against-math.patch
Thomas Claveirole 51c9ee0655 libfcgi: link with libm when needed
libfcgi uses frexp() and thus should link with libm, but fails to do
so.  Thus link errors with programs that use libfcgi (the bug does
appear only with uClibc, because the GNU libc provides frexp()
directly in libc.so).  Modify 0003-link-against-math.patch so libfcgi
links against math, instead of programs that need it.

Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-07-11 00:23:11 +02:00

17 lines
521 B
Diff

Link libfcgi against the math library.
Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
Index: b/libfcgi/Makefile.am
===================================================================
--- a/libfcgi/Makefile.am
+++ b/libfcgi/Makefile.am
@@ -18,6 +18,7 @@
os_@SYSTEM@.c
libfcgi_la_CC = @PTHREAD_CC@
libfcgi_la_CFLAGS = @PTHREAD_CFLAGS@
+libfcgi_la_LIBADD = -lm
libfcgi___la_SOURCES = $(INCLUDE_FILES) \
$(INCLUDEDIR)/fcgio.h \