buildroot/package/libfreeimage/0001-no-root-install.patch
Rémi Rérolle cbb5177a18 libfreeimage: new package
FreeImage is an Open Source library project for developers who would like to
support popular graphics image formats like PNG, BMP, JPEG, TIFF and others as
needed by today's multimedia applications.

See: http://freeimage.sourceforge.net

[Thomas:
  - add hash file
  - add dependency on !BR2_STATIC_LIBS, since the build system of
    libfreeimage always tries to build a shared library.]

Signed-off-by: Rémi Rérolle <remi.rerolle@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-04-13 22:35:27 +02:00

21 lines
752 B
Diff

Makefile.gnu: allow non-root install by not enforcing root ownserhip
Signed-off-by: Rémi Rérolle <remi.rerolle@gmail.com>
diff -ruN a/Makefile.gnu b/Makefile.gnu
--- a/Makefile.gnu 2015-04-09 16:34:02.315316841 +0200
+++ b/Makefile.gnu 2015-04-09 16:34:28.875483201 +0200
@@ -71,9 +71,9 @@
install:
install -d $(INCDIR) $(INSTALLDIR)
- install -m 644 -o root -g root $(HEADER) $(INCDIR)
- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
+ install -m 644 $(HEADER) $(INCDIR)
+ install -m 644 $(STATICLIB) $(INSTALLDIR)
+ install -m 755 $(SHAREDLIB) $(INSTALLDIR)
ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(VERLIBNAME)
ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
# ldconfig