buildroot/package/libglib2/0002-add-option-to-build-tests.patch
Adam Duskett bf023aaf10 package/libglib2: fix building on older distributions
When updating to libglib2 2.62.0, the file 0002-add-option-to-build-tests.patch
had to be refactored to work with the new build_tests checks. In the process of
refactoring, a missing check was overlooked in glib/meson.build causing
distributions with older versions of objcopy to fail because the older version
does not contain the --add-symbol argument.

Adding the check for the build_tests argument fixes the issue.

Fixes:
http://autobuild.buildroot.net/results/dcc2352a036aba9650eae8abaaa23819fc67332d

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-09-19 22:44:25 +02:00

95 lines
3 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From cdccbc6ec36243463613cb32d7058c26c3c51e16 Mon Sep 17 00:00:00 2001
From: Adam Duskett <Aduskett@gmail.com>
Date: Wed, 18 Sep 2019 09:50:00 -0700
Subject: [PATCH] add option to build tests.
Upstream won't build tests when cross-compiling. However; this means still
building the tests during a host build. Building the tests causes build
failures on older distributions such as CentOS 6 and Debian 7 because the
command `objcopy --add-symbol` is used when building the test
"test_resources2," which is not available with the older version of objcopy
provided by the distributions.
Instead, add the option 'tests' which when set to false, enforces not
building any tests, even when building the host variant.
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
---
gio/meson.build | 1 -
glib/meson.build | 3 +-
gobject/meson.build | 1 -
meson.build | 2 +-
meson_options.txt | 5 +++++
5 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/gio/meson.build b/gio/meson.build
index 9a9e621..6adc014 100644
--- a/gio/meson.build
+++ b/gio/meson.build
@@ -1010,7 +1010,6 @@ endif
subdir('fam')
# Dont build the tests unless we can run them (either natively or in an exe wrapper)
-build_tests = not meson.is_cross_build() or (meson.is_cross_build() and meson.has_exe_wrapper())
if build_tests
subdir('tests')
endif
diff --git a/glib/meson.build b/glib/meson.build
index 91a48f1..230d562 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -458,8 +458,7 @@ if enable_systemtap
)
endif
-# Dont build the tests unless we can run them (either natively or in an exe wrapper)
-build_tests = not meson.is_cross_build() or (meson.is_cross_build() and meson.has_exe_wrapper())
+build_tests = get_option('tests')
if build_tests
subdir('tests')
endif
diff --git a/gobject/meson.build b/gobject/meson.build
index c7805c5..fb5874d 100644
--- a/gobject/meson.build
+++ b/gobject/meson.build
@@ -166,7 +166,6 @@ if enable_systemtap
endif
# Dont build the tests unless we can run them (either natively or in an exe wrapper)
-build_tests = not meson.is_cross_build() or (meson.is_cross_build() and meson.has_exe_wrapper())
if build_tests
subdir('tests')
endif
diff --git a/meson.build b/meson.build
index 717d1bc..3124f28 100644
--- a/meson.build
+++ b/meson.build
@@ -2098,7 +2098,7 @@ subdir('gmodule')
subdir('gio')
subdir('fuzzing')
# Dont build the tests unless we can run them (either natively or in an exe wrapper)
-build_tests = not meson.is_cross_build() or (meson.is_cross_build() and meson.has_exe_wrapper())
+build_tests = get_option('tests')
if build_tests
subdir('tests')
endif
diff --git a/meson_options.txt b/meson_options.txt
index 2c831e3..90468a7 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -90,6 +90,11 @@ option('nls',
yield: true,
description : 'Enable native language support (translations)')
+option('tests',
+ type : 'boolean',
+ value : false,
+ description : 'Build tests')
+
option('oss_fuzz',
type : 'feature',
value : 'disabled',
--
2.21.0