buildroot/package/libiqrf/0002-use-only-c-language.patch
Peter Korsgaard 298cd8eaa2 package/*: rename patches according to the new policy
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345)

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-02-03 14:52:56 +01:00

30 lines
813 B
Diff

Use only the C language
libirqf is written completely in C, but by default, CMake assumes that
both C and C++ are used, and therefore verifies that a C++ compiler is
installed. This may not necessarily be the case for a C-only package
in Buildroot.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/src/CMakeLists.txt
===================================================================
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,3 @@
-project(iqrf)
-
set (iqrf_version_major 0)
set (iqrf_version_minor 1)
set (iqrf_version_patch 2)
Index: b/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,5 @@
+project(iqrf C)
+
cmake_minimum_required(VERSION 2.8.1)
enable_testing()