buildroot/package/libsquish/0001-Makefile-add-f-option-for-ln-to-remove-existing-dest.patch
Romain Naour b621273755 package/libsquish: really install shared library
While testing the new supertuxkart 0.10-beta1 version, the build
failed due to missing libsquash shared library.

Indeed, by default (see config file) the shared library is not build
and all symlinks created by LIBSQUISH_INSTALL_{STAGING,TARGET}_CMDS
are curently broken.

To fix that, add USE_SHARED=1 to LIBSQUISH_MAKE_ENV.

Also add a patch to allow reinstall the package.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-01-12 15:35:28 +01:00

33 lines
1.1 KiB
Diff

From 1e541293ac19c49f886220b64de6006c5c700144 Mon Sep 17 00:00:00 2001
From: Romain Naour <romain.naour@gmail.com>
Date: Sat, 12 Jan 2019 12:50:54 +0100
Subject: [PATCH] Makefile: add -f option for ln to remove existing destination
files
While reinstalling the library, all symlinks are present.
Ask ln to remove them with -f.
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index fd7d6c8..2683819 100644
--- a/Makefile
+++ b/Makefile
@@ -25,8 +25,8 @@ install: $(LIB) $(LIBA) libsquish.pc
$(INSTALL_FILE) $(LIBA) $(INSTALL_DIR)/$(LIB_PATH)
ifneq ($(USE_SHARED),0)
$(INSTALL_FILE) $(LIB) $(INSTALL_DIR)/$(LIB_PATH)
- ln -s $(LIB) $(INSTALL_DIR)/$(LIB_PATH)/$(SOLIB)
- ln -s $(LIB) $(INSTALL_DIR)/$(LIB_PATH)/libsquish.so
+ ln -sf $(LIB) $(INSTALL_DIR)/$(LIB_PATH)/$(SOLIB)
+ ln -sf $(LIB) $(INSTALL_DIR)/$(LIB_PATH)/libsquish.so
$(INSTALL_DIRECTORY) $(INSTALL_DIR)/$(LIB_PATH)/pkgconfig
$(INSTALL_FILE) libsquish.pc $(INSTALL_DIR)/$(LIB_PATH)/pkgconfig
endif
--
2.14.5