buildroot/package/linknx/0002-configure.ac-always-define-CPPUNIT.patch
Fabrice Fontaine febf860990 package/linknx: fix build without cppunit
Fixes:
 - http://autobuild.buildroot.org/results/4b042b7e18425690ec26b4977865516bedcb9edb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-04-22 22:28:33 +02:00

35 lines
1,018 B
Diff

From 1b4a770af42f7d33ad174524b94ea4d2fc7133da Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 21 Apr 2019 19:31:50 +0200
Subject: [PATCH] configure.ac: always define CPPUNIT
Fixes:
- http://autobuild.buildroot.org/results/4b042b7e18425690ec26b4977865516bedcb9edb
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/linknx/linknx/pull/42]
---
configure.ac | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 779fd6f..51d8ae6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,8 +145,11 @@ if test x"$WITH_CPPUNIT" != xno; then
AC_DEFINE([HAVE_CPPUNIT], [1], [cppunit])
AC_SUBST(CPPUNIT_CFLAGS)
AC_SUBST(CPPUNIT_LIBS)
- ])
+ AM_CONDITIONAL([CPPUNIT], true)
+ ],[AM_CONDITIONAL([CPPUNIT], false)])
fi
+else
+ AM_CONDITIONAL([CPPUNIT], false)
fi
dnl #########################################################################
--
2.20.1