buildroot/package/midori/0002-gcr-for-x11-only.patch
Gustavo Zacarias 54bbd88b1f midori: bump to version 0.5.11
Also drop BR2_PACKAGE_MIDORI_HTTPS option since it's now handled in the
webkitgtk package to satisfy MiniBrowser.

This version can't work with the older webkitgtk24 engine so it switches
to the new version.

Also make gcr support conditional on x11 support for libgtk3, it doesn't
work otherwise.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-04-30 19:10:07 +02:00

33 lines
1.1 KiB
Diff

GCR support only works/is useful with X11 support.
Reported upstream: https://bugs.launchpad.net/midori/+bug/1515985
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura midori-0.5.11.orig/CMakeLists.txt midori-0.5.11/CMakeLists.txt
--- midori-0.5.11.orig/CMakeLists.txt 2015-11-12 13:41:02.045898814 -0300
+++ midori-0.5.11/CMakeLists.txt 2015-11-12 14:00:09.765545018 -0300
@@ -175,18 +175,14 @@
set(PKGS ${PKGS} zeitgeist-2.0)
endif()
-if (WIN32)
- add_definitions("-DGCR_VERSION=\"No\"")
-else ()
- if (USE_GTK3)
- pkg_check_modules(GCR REQUIRED gcr-3>=2.32)
- else ()
- pkg_check_modules(GCR REQUIRED gcr-base-3>=2.32)
- endif ()
+if (USE_GTK3 AND X11)
+ pkg_check_modules(GCR REQUIRED gcr-3>=2.32)
add_definitions("-DGCR_VERSION=\"${GCR_VERSION}\"")
add_definitions("-DHAVE_GCR")
set(OPTS_INCLUDE_DIRS ${OPTS_INCLUDE_DIRS} ${GCR_INCLUDE_DIRS})
set(OPTS_LIBRARIES ${OPTS_LIBRARIES} ${GCR_LIBRARIES})
+else ()
+ add_definitions("-DGCR_VERSION=\"No\"")
endif ()
if (HALF_BRO_INCOM_WEBKIT2)