buildroot/package/nfs-utils/0003-Let-the-configure-script-find-getrpcbynumber-in-libt.patch
Maxime Hadjinlian e5e31fe92d nfs-utils: Bump version
Refresh the patches (Thanks to Thomas Petazzoni's work)

Patches removed:
0001-build-avoid-AM_CONDITIONAL-in-conditional-execution.patch
0004-fix-build-with-uClibc.patch
0004-fix-build-with-uClibc.patch
0005-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch
0007-sockaddr-h-needs-stddef-h-for-NULL.patch
0008-tirpc-with-pkgconfig.patch

Patches modified:
0002-Patch-taken-from-Gentoo.patch
0003-Switch-legacy-index-in-favour-of-strchr.patch
0006-Let-the-configure-script-find-getrpcbynumber-in-libt.patch

Patch addedd:
0004-statd-Fix-test-for-foreground-mode.patch

Also, change source of the package to git repository (and remove the hash,
sourceforce is clearly not a platform which can be trusted nowadays)

Rework the startup script to accomodate new rpc.statd
The startup scripts now uses rcp.statd -F for a startup in foreground,
also we avoid starting it twice, it makes rcp.statd crash the whole
script.

[Thomas: add patch to fix rpc.statd foreground/daemon mode backported
from upstream, and fix the S60nfs init script to not use the -F option
of rpc.statd.]

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-07-13 12:54:42 +02:00

47 lines
1.8 KiB
Diff

From 87f88b28ac01b6449463f00b660fe7416d7f9a55 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Sat, 10 Nov 2012 18:53:03 +0100
Subject: [PATCH] Let the configure script find getrpcbynumber in libtirpc
The getrpcbynumber() function may not be available in the C library,
but only in the libtirpc library. Take this into account when checking
for the existence of getrpcbynumber() and getrpcbynumber_r().
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
configure.ac | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 8e427e3..6e42c96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -433,11 +433,23 @@ AC_FUNC_STAT
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([alarm atexit dup2 fdatasync ftruncate getcwd \
gethostbyaddr gethostbyname gethostname getmntent \
- getnameinfo getrpcbyname getrpcbynumber getrpcbynumber_r getifaddrs \
+ getnameinfo getrpcbyname getifaddrs \
gettimeofday hasmntopt inet_ntoa innetgr memset mkdir pathconf \
ppoll realpath rmdir select socket strcasecmp strchr strdup \
strerror strrchr strtol strtoul sigprocmask name_to_handle_at])
+save_CFLAGS=$CFLAGS
+save_LIBS=$LIBS
+CFLAGS="$CFLAGS $AM_CPPFLAGS"
+LIBS="$LIBS $LIBTIRPC"
+AC_CHECK_FUNCS([getrpcbynumber getrpcbynumber_r])
+CFLAGS=$save_CFLAGS
+LIBS=$save_LIBS
+
+if test "$ac_cv_func_getrpcbynumber_r" != "yes" -a "$ac_cv_func_getrpcbynumber" != "yes"; then
+ AC_MSG_ERROR([Neither getrpcbynumber_r nor getrpcbynumber are available])
+fi
+
dnl *************************************************************
dnl Check for data sizes
dnl *************************************************************
--
2.1.0