buildroot/package/openipmi/0001-Avoid-searching-host-library-path.patch
Joel Stanley 74c5081467 openipmi: bump to version 2.0.24
Some changes in addition to the version bump:

 - The uint32_t patch is now upstream
 - Drop --no-glib12 flag as support was removed in 2.0.23
 - The host library path patch was refreshed

Signed-off-by: Joel Stanley <joel@jms.id.au>
Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Arnout: remove uint32_t patch from hash file]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2017-09-19 22:06:15 +02:00

53 lines
2.1 KiB
Diff

From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Baruch Siach <baruch@tkos.co.il>
Date: Wed, 22 Jul 2015 07:04:33 +0300
Subject: [PATCH] Avoid searching host library path
The $(libdir) variable points to the location of the directory on the target
system, /usr/lib by default. When cross compiling this directory contains the
host libraries which may be different than target libraries. Don't use
$(libdir) in the library search path.
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Joel Stanley <joel@jms.id.au>
---
cmdlang/Makefile.am | 3 +--
unix/Makefile.am | 6 ++----
2 files changed, 3 insertions(+), 6 deletions(-)
diff --git a/cmdlang/Makefile.am b/cmdlang/Makefile.am
index 264ee12be79f..0b3843784656 100644
--- a/cmdlang/Makefile.am
+++ b/cmdlang/Makefile.am
@@ -15,8 +15,7 @@ libOpenIPMIcmdlang_la_SOURCES = cmdlang.c cmd_domain.c cmd_entity.c cmd_mc.c \
libOpenIPMIcmdlang_la_LIBADD = -lm \
$(top_builddir)/utils/libOpenIPMIutils.la \
$(top_builddir)/lib/libOpenIPMI.la
-libOpenIPMIcmdlang_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \
- -L$(libdir)
+libOpenIPMIcmdlang_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION)
bin_PROGRAMS = openipmish
diff --git a/unix/Makefile.am b/unix/Makefile.am
index 5128839dad13..bd0f897ba8d6 100644
--- a/unix/Makefile.am
+++ b/unix/Makefile.am
@@ -10,14 +10,12 @@ lib_LTLIBRARIES = libOpenIPMIposix.la libOpenIPMIpthread.la
libOpenIPMIpthread_la_SOURCES = posix_thread_os_hnd.c selector.c
libOpenIPMIpthread_la_LIBADD = -lpthread $(GDBM_LIB) \
$(top_builddir)/utils/libOpenIPMIutils.la $(RT_LIB)
-libOpenIPMIpthread_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \
- -L$(libdir)
+libOpenIPMIpthread_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION)
libOpenIPMIposix_la_SOURCES = posix_os_hnd.c selector.c
libOpenIPMIposix_la_LIBADD = $(top_builddir)/utils/libOpenIPMIutils.la \
$(GDBM_LIB) $(RT_LIB)
-libOpenIPMIposix_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \
- -L$(libdir)
+libOpenIPMIposix_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION)
noinst_HEADERS = heap.h