buildroot/package/oracle-mysql/0002-use-new-readline-iface.patch
Ryan Coe 3d707d2b4f mysql: rename package to oracle-mysql, make a virtual package
This commit turns mysql into a virtual package, after renaming the
original mysql package to oracle-mysql. This way, all existing packages
that "depends on" or "select" BR2_PACKAGE_MYSQL continue to work with no
modification.

Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-12-17 15:01:07 +01:00

22 lines
682 B
Diff

Tell MySQL to use the new readline interface even when an external
readline is being used.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
configure.in | 1 +
1 file changed, 1 insertion(+)
Index: mysql-5.1.53/configure.in
===================================================================
--- mysql-5.1.53.orig/configure.in
+++ mysql-5.1.53/configure.in
@@ -2689,6 +2689,7 @@
# this way we avoid linking commercial source with GPL readline
readline_link="-lreadline"
want_to_use_readline="yes"
+ AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
elif [test "$mysql_cv_libedit_interface" = "yes"]
then
# Use libedit