buildroot/package/oracle-mysql/0004-Fix-gen_lex_hash-execution.patch
Ryan Coe 3d707d2b4f mysql: rename package to oracle-mysql, make a virtual package
This commit turns mysql into a virtual package, after renaming the
original mysql package to oracle-mysql. This way, all existing packages
that "depends on" or "select" BR2_PACKAGE_MYSQL continue to work with no
modification.

Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-12-17 15:01:07 +01:00

33 lines
1 KiB
Diff

Makefile: fix cross-compiling the server
MySQL Makefile believes it can run code it just compiled, to
generate a header. This does not work for cross-compilation.
Instead, use a pre-installed host-version of the required tool.
Signed-off-by: Marcelo Gutierrez (UTN/FRH) <kuyurix@gmail.com>
--- mysql-5.1.70/sql/Makefile.am
+++ mysql-5.1.70.patch/sql/Makefile.am
@@ -177,7 +177,7 @@
# this avoid the rebuild of the built files in a source dist
lex_hash.h: gen_lex_hash.cc lex.h
$(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@-t
+ gen_lex_hash$(EXEEXT) > $@-t
$(MV) $@-t $@
# For testing of udf_example.so
--- mysql-5.1.70/sql/Makefile.in
+++ mysql-5.1.70.patch/sql/Makefile.in
@@ -1310,7 +1310,7 @@
# this avoid the rebuild of the built files in a source dist
lex_hash.h: gen_lex_hash.cc lex.h
$(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
- ./gen_lex_hash$(EXEEXT) > $@-t
+ gen_lex_hash$(EXEEXT) > $@-t
$(MV) $@-t $@
# We might have some stuff not built in this build, but that we want to install