buildroot/package/prboom/0002-configure-remove-predefined-O2-optimization-flag.patch
Giulio Benetti 34bcc4c6b0 package/prboom: avoid using hardcoded optimization flags
Package prboom builds using -O2 flag ignoring Buildroot settings, this
is due to the fact that -O2 is appended at the end of compiler flags.

Remove -O2 from 'configure.ac' file and set PRBOOM_AUTORECONF to YES,
this way CFLAGS_OPTS will contain Buildroot TARGET_CFLAGS.

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-08-03 12:57:46 +02:00

22 lines
861 B
Diff

configure: remove predefined -O2 optimization flag
CFLAGS_OPT variable forces to use -O2 optimization flag denying the
possibility to use different optimization flag values.
Remove -O2 flag from CFLAGS_OPT.
Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
diff -urpN prboom-2.5.0.orig/configure.ac prboom-2.5.0/configure.ac
--- prboom-2.5.0.orig/configure.ac 2019-06-20 14:07:45.058481879 +0200
+++ prboom-2.5.0/configure.ac 2019-06-20 14:09:05.066238825 +0200
@@ -48,7 +48,7 @@ else
fi
dnl --- cph: work out flags to pass to compiler
-CFLAGS_OPT="-O2 -fomit-frame-pointer"
+CFLAGS_OPT="-fomit-frame-pointer"
AC_C_COMPILE_FLAGS(-Wall)
dnl --- Option to enable debugging
AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[turns on various debugging features, like range checking and internal heap diagnostics]),,enable_debug="no")