buildroot/package/qt5cinex/0001-Fix-execution-problem-with-Qt5.3.patch
Pierre Le Magourou 2b266815cb qt5cinex: Add new Qt5CinematicExperience package.
[Thomas:
 - Change the dependency logic in the Config.in file. We don't want to
   have a 'depends on BR2_PACKAGE_QT5GRAPHICALEFFECTS': it should be
   selected automatically. Instead, let's have a dependency on Qt5 and
   OpenGL, and select everything else automatically. A comment is
   added, shown only when Qt5 is available, on the right platforms
   (which have JSCore support), to explain that we need an OpenGL
   backend.
 - Change the prompt of the package to be qt5cinex, to match the
   package name.
 - Replace "High-definition support" by "High-definition version".
 - Fix a typo in the Config.in help text: definifition -> definition.
 - Add a comment in the .mk file explaining why we install a wrapper
   shell script (explanation taken from Pierre's e-mail).
 - Fix indentation in the install target commands.
 - Keep only sha256 hashes, those are sufficient. Replace the comment
   in the hash file by the more traditional "Locally computed".]

Signed-off-by: Pierre Le Magourou <pierre.lemagourou@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-01-07 21:37:55 +01:00

65 lines
1.8 KiB
Diff

From 9b045ee7988daf3bb4c7cbe1ed1b9d744820e82b Mon Sep 17 00:00:00 2001
From: Pierre Le Magourou <pierre.lemagourou@openwide.fr>
Date: Mon, 15 Dec 2014 11:54:51 +0100
Subject: [PATCH] Fix execution problem with Qt5.3.
This patch has been inspired from Open Embedded meta-qt5.
Signed-off-by: Pierre Le Magourou <pierre.lemagourou@openwide.fr>
---
content/SettingsView.qml | 4 ++--
content/Switch.qml | 8 ++++----
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/content/SettingsView.qml b/content/SettingsView.qml
index 7944803..a0ddcc8 100644
--- a/content/SettingsView.qml
+++ b/content/SettingsView.qml
@@ -127,8 +127,8 @@ Item {
Switch {
text: "Do you l-o-v-e colors?"
checked: settings.showColors
- onText: "Yes"
- offText: "No!"
+ textON: "Yes"
+ textOFF: "No!"
onCheckedChanged: {
settings.showColors = checked;
}
diff --git a/content/Switch.qml b/content/Switch.qml
index 967c03f..66955fc 100644
--- a/content/Switch.qml
+++ b/content/Switch.qml
@@ -6,8 +6,8 @@ Item {
property alias text: textItem.text
property bool checked: false
- property string onText: "On"
- property string offText: "Off"
+ property string textON: "On"
+ property string textOFF: "Off"
QtObject {
id: priv
@@ -120,7 +120,7 @@ Item {
color: "#000000"
font.pixelSize: 18
font.bold: true
- text: onText
+ text: textON
}
Text {
anchors.verticalCenter: parent.verticalCenter
@@ -129,7 +129,7 @@ Item {
color: "#ffffff"
font.pixelSize: 18
font.bold: true
- text: offText
+ text: textOFF
}
Image {
--
2.1.3