buildroot/package/sp-oops-extract/0001-Make-the-Makefile-more-cross-compiler-friendly.patch
Doug Kehn 22212f15e4 package/sp-oops-extract: new package
A tool for extracting OOPS/panic logs from MTD.

Tested using arm-buildroot-linux-gnueabihf toolchain.

[Thomas:
 - use sp-oops-extract instead of sp_oops_extract as the Config.in
   prompt and in the .mk file comment
 - remove @ in front of the build and install commands.
 - use $(TARGET_CONFIGURE_OPTS) instead of manually passing CC, AR,
   LD, CFLAGS and LDFLAGS.]

Signed-off-by: Doug Kehn <rdkehn@yahoo.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-08-29 23:12:48 +02:00

23 lines
642 B
Diff

Fetch from: https://github.com/Schischu/ptxdist_sh/tree/master/patches/sp-oops-extract-0.0.7
From: Bernhard Walle <walle@corscience.de>
Date: Wed, 21 Mar 2012 15:55:06 +0100
Subject: [PATCH] Make the Makefile more cross-compiler friendly
Signed-off-by: Bernhard Walle <walle@corscience.de>
---
src/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Makefile b/src/Makefile
index cf5b550..e05eb1f 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -9,4 +9,4 @@ distclean: clean
$(RM) $(TARGETS)
sp-oops-extract: oopslog.c
- gcc -Wall -s -o $@ $^
+ $(CC) $(LDFLAGS) $(CPPFLAGS) $(CFLAGS) -Wall -o $@ $^