buildroot/package/subversion/0001-dont-mangle-cflags.patch
Vicente Olivert Riera 4965192f60 subversion: bump to version 1.9.2
- Bump to version 1.9.2.
- Update the hash file.
- Use a tar.bz2 tarball to save space and bandwidth.
- Fix a typo in the berkeley-db configure option.
- Remove non-existent configure options: neon, gssapi and ssl.
- Remove neon dependency: is not needed to build subversion.
- Tweak the 0001-dont-mangle-cflags.patch for the 1.9.2 version and to
  patch configure.ac instead of configure.
- Add a new 0002-disable-macos-specific-features.patch to remove a
  configure check for Mach-O (and two more) which breaks the build when
  cross-compiling.
- Enable autoreconf since we are patching the configure.ac.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-09-28 22:15:45 +02:00

25 lines
1.1 KiB
Diff

[PATCH] configure.ac: don't mangle CFLAGS
Ensure that the sed expression to strip debugging options from CFLAGS
doesn't mangle flags like -mfloat-gprs=double, breaking the build.
[Vincent: adapt to 1.9.2 and patch configure.ac instead of configure]
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
diff -Nrup a/configure.ac b/configure.ac
--- a/configure.ac 2015-07-27 00:03:10.000000000 +0100
+++ b/configure.ac 2015-09-28 10:33:39.175048493 +0100
@@ -1110,8 +1110,8 @@ if test "$enable_debugging" = "yes" ; th
CXXFLAGS="$CXXFLAGS -DSVN_DEBUG -DAP_DEBUG"
elif test "$enable_debugging" = "no" ; then
AC_MSG_NOTICE([Disabling debugging])
- CFLAGS=["`echo $CFLAGS' ' | $SED -e 's/-g[0-9] //g' -e 's/-g //g'`"]
- CXXFLAGS=["`echo $CXXFLAGS' ' | $SED -e 's/-g[0-9] //g' -e 's/-g //g'`"]
+ CFLAGS=["`echo $CFLAGS' ' | $SED -e 's/-g[0-9]* //g'`"]
+ CXXFLAGS=["`echo $CXXFLAGS' ' | $SED -e 's/-g[0-9]* //g'`"]
dnl Compile with NDEBUG to get rid of assertions
CFLAGS="$CFLAGS -DNDEBUG"
CXXFLAGS="$CXXFLAGS -DNDEBUG"