buildroot/package/suricata/0001-configure.ac-fix-static-build-with-pcap.patch
Fabrice Fontaine c0d8743e53 package/suricata: needs autoreconf
Commit 1ce2db1090 was the second patch of
a third patch serie, it was applied without the first one so
AUTORECONF=YES was missing and patch number was wrong. Fix these two
errors.

Fixes:
 - http://autobuild.buildroot.org/results/a26d3493399c43faa37d2d67d772e0833971a9de

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2019-05-28 22:36:59 +02:00

30 lines
957 B
Diff

From 2660123b0c16d7f6a49747711be676c4119561c9 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Wed, 24 Apr 2019 20:35:20 +0200
Subject: [PATCH] configure.ac: fix static build with pcap
pcap can depends on nl-3 so use pkg-config to find these dependencies
otherwise all AC_CHECK_LIB calls will fail when building statically
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: not sent yet]
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index ee59c9d8e..5ec341231 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1331,6 +1331,7 @@
AC_CHECK_HEADERS([pcap.h pcap/pcap.h pcap/bpf.h])
LIBPCAP=""
+ PKG_CHECK_MODULES([PCAP],libpcap,[CPPFLAGS="${CPPFLAGS} ${PCAP_CFLAGS}" LIBS="${LIBS} ${PCAP_LIBS}"],[])
AC_CHECK_LIB(${PCAP_LIB_NAME}, pcap_open_live,, LIBPCAP="no")
if test "$LIBPCAP" = "no"; then
echo
--
2.20.1