buildroot/package/tinydtls/0002-Fix-compilation-of-tests-directory.patch
Fabrice Fontaine 5bd7f26539 tinydtls: new package
tinydtls is a library for Datagram Transport Layer Security
(DTLS) covering both the client and the server state machine.
It is implemented in C and provides support for the mandatory
cipher suites specified in CoAP.

https://sourceforge.net/projects/tinydtls

Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-07-30 15:34:57 +02:00

32 lines
797 B
Diff

From c629a108f5d03cd365c0ba71143ad507f6cd97f0 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fabrice.fontaine@orange.com>
Date: Thu, 28 Jul 2016 08:36:06 +0200
Subject: [PATCH] Fix compilation of tests directory
binaries in tests subdirectory depends on libtinydtls so add $(LIB) dependency
for dirs target in Makefile.in
Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
---
Makefile.in | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 7dcd424..c493705 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -68,8 +68,8 @@ check:
echo top_builddir: $(top_builddir)
$(MAKE) -C tests check
-dirs: $(SUBDIRS)
- for dir in $^; do \
+dirs: $(LIB) $(SUBDIRS)
+ for dir in $(SUBDIRS); do \
$(MAKE) -C $$dir ; \
done
--
2.7.4