buildroot/package/tstools/0001-build-get-along-with-buildroot.patch
Vicente Olivert Riera 2c9aceea90 tstools: GitHub migration
tstools has migrated to GitHub, so let's use this opportuninty to rework
this package as well.

- Change site to GitHub.
- No releases of tags yet, so let's use the latest commit ID from the
  master branch as a version.
- There is currently no license file attributed to tstools, so state that
  in the tstools.mk file and add empty license file variable. This issue is
  being tracked upstream: https://github.com/kynesim/tstools/issues/32
- Wrap the help text in the Config.in to 72 characters, and also change
  the project URL to the GitHub one.
- Add a hash file.
- Rename the patch to use a four digit numbering (001 -> 0001).

[Peter: leave license as MPLv1.1, adjust comment to match]
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-10-20 16:33:07 +02:00

41 lines
1.1 KiB
Diff

From 44f80bce0914d4d9c5e7486c7cdb521ba637b324 Mon Sep 17 00:00:00 2001
From: Tzu-Jung Lee <tjlee@ambarella.com>
Date: Fri, 19 Jul 2013 22:45:18 +0800
Subject: [PATCH] build: get along with buildroot
Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
---
Makefile | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/Makefile b/Makefile
index 2c3568e..98bb994 100644
--- a/Makefile
+++ b/Makefile
@@ -34,12 +34,6 @@ SHELL = /bin/sh
.SUFFIXES:
.SUFFIXES: .c .o
-ifdef CROSS_COMPILE
-CC = $(CROSS_COMPILE)gcc
-else
-CC = gcc
-endif
-
# Use WARN=1 periodically to get too many warnings...
ifdef WARN
WARNING_FLAGS = -Wall -W -Wfloat-equal -Wundef -Wshadow -Wpointer-arith -Wcast-qual -Wconversion -Wmissing-prototypes -Wmissing-declarations -Wunreachable-code -Winline
@@ -452,3 +446,9 @@ test_lists: $(BINDIR)/test_nal_unit_list $(BINDIR)/test_es_unit_list
@echo +++ Testing ES unit lists
$(BINDIR)/test_es_unit_list
@echo +++ Test succeeded
+
+.PHONY: install
+install:
+ @for i in $(PROGS); do \
+ cp -f $$i $(DESTDIR)/usr/bin/; \
+ done
--
1.8.3.2