buildroot/package/usb_modeswitch/0001-Makefile-allow-extra-configure-flags-to-be-passed-to.patch
Peter Korsgaard 29cccab447 usb_modeswitch: explicitly set --host / --build for the embedded jimtcl
Fixes:
http://autobuild.buildroot.net/results/106/106af20196089e74c35daabdae46f030981600bd/

Otherwise the (handwritten) configure script uses a config.guess script from
2010 to figure out the build host, breaking builds on ppc64le hosts.

The result of --host / --build is only used to detect if we are building for
Windows or not, which is why things are working on x86(-64) build hosts
without specifying --host even though we are cross compiling - But this may
change in the future, so we better pass the correct values.

Passing extra jimtcl configure flags is unfortunately not forseen in the
usb_modeswitch Makefile, so add a small patch making this possible.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2017-11-05 20:49:47 +01:00

30 lines
842 B
Diff

From 1309df373c882f27f476130b06746a6d1e1a0f85 Mon Sep 17 00:00:00 2001
From: Peter Korsgaard <peter@korsgaard.com>
Date: Fri, 3 Nov 2017 23:21:44 +0100
Subject: [PATCH] Makefile: allow extra configure flags to be passed to jimtcl
on the make command line
E.G. to pass --host / --build for cross compilation.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index a151e2a..94dabd9 100644
--- a/Makefile
+++ b/Makefile
@@ -19,7 +19,7 @@ TCL ?= $(HOST_TCL)
else
TCL ?= /usr/bin/tclsh
endif
-JIM_CONFIGURE_OPTS = --disable-lineedit \
+override JIM_CONFIGURE_OPTS += --disable-lineedit \
--with-out-jim-ext="stdlib posix load signal syslog" --prefix=/usr
.PHONY: clean install install-common uninstall \
--
2.11.0