buildroot/package/valgrind/0001-workaround-SIGSEGV-on-PPC.patch
Peter Seiderer a24893ceee valgrind: bump version to 3.11.0
- rebase patch 0001-workaround-SIGSEGV-on-PPC.patch
- remove upstream applied patches
  0002-Fix-configure-for-Linux-kernel-4.0-rc1.patch
  0004-configure.ac-Generalize-glibc-version-check.patch
- rebase 0003-add-missing-ptrace-getsiginfo-on-powerpc.patch
  (convert to git patch format, rename to
  0002-Define-PTRACE_GETSIGINFO-on-PowerPC-when-not-availab.patch)
- remove legacy VALGRIND_AUTORECONF=YES (no more patch touching confgure.ac)
- add '--disable-ubsan' for new undefined behaviour sanitiser option

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-10-31 15:42:36 +01:00

33 lines
866 B
Diff

From ff29b837f21a69c79289c3a87b03f8c23e05616e Mon Sep 17 00:00:00 2001
From: Pierre Habouzit <madcoder@debian.org>
Date: Tue, 10 May 2011 23:11:45 +0200
Subject: [PATCH] workaround SIGSEGV on PPC.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Pierre Habouzit <madcoder@debian.org>
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
---
coregrind/m_machine.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/coregrind/m_machine.c b/coregrind/m_machine.c
index 6110c93..298a00e 100644
--- a/coregrind/m_machine.c
+++ b/coregrind/m_machine.c
@@ -27,6 +27,10 @@
The GNU General Public License is contained in the file COPYING.
*/
+#ifdef __powerpc__
+# pragma GCC optimize ("-O0")
+#endif
+
#include "pub_core_basics.h"
#include "pub_core_vki.h"
#include "pub_core_threadstate.h"
--
2.1.4