buildroot/package/vpnc/0001-Makefile-allow-to-override-the-PREFIX-variable.patch
Thomas Petazzoni b989436447 vpnc: bump to newer upstream version
While the official upstream has not published any new tarball, they
have continued to update their Subversion repository with additional
changes. This commit therefore updates the vpnc package to a newer
version, using the Github repository that replicates the original
Subversion repository.

Since the update required some updates to the patches, we took this
opportunity to split them in more fine-grained changes, and document
them more properly. Consequently:

 - The patch 0001 that fixes the Makefile gets split into 3 patches,
   0001, 0002 and 0003, each for one specific issue.

 - Patch 0002 to disable building the manpages gets changed into a
   solution that is potentially upstreamable, and is now patch 0004.

 - A new patch 0005 is added to specify a custom libgcrypt-config
   path, since this tool is now used to know how to link with
   libgcrypt.

 - The SUSv3 function removal patch is now patch 0006, and gains a
   better commit log.

Also, this vpnc version now depends on gnutls, which basically is a
better replacement for OpenSSL, whose support was not enabled by
default due to licensing issues (vpnc is under the GPL, which isn't
compatible with the OpenSSL license).

Patches have been submitted upstream:
http://lists.unix-ag.uni-kl.de/pipermail/vpnc-devel/2016-June/004186.html

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-06-03 16:12:26 +02:00

32 lines
766 B
Diff

From 7314d232f8e85879d8f4c311ced44ee5b21fb239 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Wed, 10 Feb 2016 23:26:27 +0100
Subject: [PATCH] Makefile: allow to override the PREFIX variable
Some people may not want to install in /usr/local, so this commit
makes it possible to override the PREFIX variable from the make
command line.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 69f5aca..f9a6781 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@
# $Id$
DESTDIR=
-PREFIX=/usr/local
+PREFIX?=/usr/local
ETCDIR=/etc/vpnc
BINDIR=$(PREFIX)/bin
SBINDIR=$(PREFIX)/sbin
--
2.6.4