buildroot/package/ejabberd/0001-remove-deps.patch
Johan Oudinet 8290f2ea11 ejabberd: new package.
[Thomas:
 - Adjust the comment about the dependency on erlang
 - Fix license to be 'GPLv2+ with OpenSSL exception' and not just 'GPLv2+'
 - Use double quotes instead of simple quotes in the .mk file.
 - Don't use the EJABBERD_MAKE_ENV variable, since it's not defined
   anywhere.
 - Remove the 0007-fix-init.patch patch, since we're not using the
   init script provided by ejabberd, and rename
   0008-fix-install-permissions.patch to
   0007-fix-install-permissions.patch.]

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-02-03 10:23:39 +01:00

21 lines
784 B
Diff

Description: remove make targets for deps
Without this patch, dependencies would be downloaded and compiled
using rebar at build time.
Author: Philipp Huebner <debalance@debian.org>
Index: ejabberd/rebar.config.script
===================================================================
--- ejabberd.orig/rebar.config.script
+++ ejabberd/rebar.config.script
@@ -126,9 +126,7 @@ Config = [{erl_opts, Macros ++ HiPE ++ D
{sub_dirs, ["rel"]},
{keep_build_info, true},
{ct_extra_params, "-include "
- ++ filename:join([Cwd, "tools"])},
- {post_hooks, PostHooks ++ CfgPostHooks},
- {deps, Deps ++ CfgDeps}],
+ ++ filename:join([Cwd, "tools"])}],
%%io:format("ejabberd configuration:~n ~p~n", [Config]),
Config.