buildroot/package/gawk/0001-no-versioned.patch
Gustavo Zacarias df099b50f8 gawk: bump to version 4.1.2
Drop LIBTOOL/GETTEXTIZE as well since it's no longer bundled with a beta
version.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-04-29 23:27:03 +02:00

27 lines
874 B
Diff

Disabled versioned installation of binaries to save space.
Also use symlinks where it's appropiate.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Gustavo: update for 4.1.2]
diff -Nura gawk-4.1.2.orig/Makefile.in gawk-4.1.2/Makefile.in
--- gawk-4.1.2.orig/Makefile.in 2015-04-29 16:11:09.367925925 -0300
+++ gawk-4.1.2/Makefile.in 2015-04-29 16:11:25.308466495 -0300
@@ -554,7 +554,7 @@
CLEANFILES = core core.*
# We want hard links for install-exec-hook, below
-LN = ln
+LN = $(LN_S)
# For some make's, e.g. OpenBSD, that don't define this
RM = rm -f
@@ -1173,6 +1173,7 @@
# (This is done universally, which may not always be right, but
# there's no easy way to distinguish GNU from non-GNU systems.)
install-exec-hook:
+foo:
(cd $(DESTDIR)$(bindir); \
$(LN) gawk$(EXEEXT) gawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \
if [ ! -f awk$(EXEEXT) ]; \