buildroot/package/kbd/0001-link-against-libintl.patch
Peter Korsgaard 298cd8eaa2 package/*: rename patches according to the new policy
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345)

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-02-03 14:52:56 +01:00

35 lines
1.3 KiB
Diff

Make sure we link against libintl if needed
We modify directly the Makefile.in so that we don't have to
autoreconfigure the package, which doesn't work because packages using
gettext need the autopoint tool for their autoregeneration step and
this thing doesn't work (yet) in Buildroot.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: kbd-1.15.2/src/Makefile.am
===================================================================
--- kbd-1.15.2.orig/src/Makefile.am 2011-05-22 16:08:51.144530776 +0200
+++ kbd-1.15.2/src/Makefile.am 2011-05-22 16:09:09.892530778 +0200
@@ -5,6 +5,8 @@
AM_CPPFLAGS = -DDATADIR=\"$(datadir)\" -DLOCALEDIR=\"$(localedir)\" $(WARNINGS) \
-funit-at-a-time
+LDADD = @INTLLIBS@
+
OLDPROGS = mapscrn loadunimap
PROGS = \
dumpkeys loadkeys showkey setfont showconsolefont \
Index: kbd-1.15.2/src/Makefile.in
===================================================================
--- kbd-1.15.2.orig/src/Makefile.in 2011-05-22 16:10:27.540530777 +0200
+++ kbd-1.15.2/src/Makefile.in 2011-05-22 16:10:51.172530778 +0200
@@ -26,6 +26,7 @@
install_sh_PROGRAM = $(install_sh) -c
install_sh_SCRIPT = $(install_sh) -c
INSTALL_HEADER = $(INSTALL_DATA)
+LDADD = @INTLLIBS@
transform = $(program_transform_name)
NORMAL_INSTALL = :
PRE_INSTALL = :