buildroot/package/libcec/0001-remove-Wno-psabi.patch
Thomas Petazzoni 450023b2a2 libcec: add patch to fix build on Blackfin
Blackfin uses a gcc 4.3 compiler, which does not support the
-Wno-psabi option. Since it is non essential, this commit adds a patch
to remove the usage of this option.

Fixes:

  http://autobuild.buildroot.net/results/3ab/3ab146583fa57ef7d6e67530b3274df1a844c7e1/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-03-21 09:52:59 +01:00

22 lines
633 B
Diff

Do not use -Wno-psabi option
This option was added in gcc 4.5, and Buildroot still uses gcc 4.3 on
some architectures. Since it's non essential (only disables some
warning), let's get rid of it.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -137,7 +137,7 @@
use_udev="no"
use_adapter_detection="yes"
use_lockdev="no"
-SUPPRESS_MANGLING_WARNINGS=" -Wno-psabi"
+SUPPRESS_MANGLING_WARNINGS=""
case "${host}" in
*-*-linux*)
## search for udev if pkg-config was found