buildroot/package/lightning/0001-cross-compilation-configure-fixes.patch
Paul Cercueil 952391db04 lightning: new package
GNU lightning is a library that generates assembly language code at
run-time.

https://www.gnu.org/software/lightning/

[Thomas:
 - Wrap list of architectures in Config.in
 - Introduce an explicit Config.in option for the disassembler
   support, since it needs both binutils and zlib, which may not be
   easy to guess.
 - Add hash file.
 - Bump to version 2.0.5.
 - Add patch to fix cross-compilation issues on ARM and x86 due to
   AC_RUN_IFELSE() tests.
 - Adjust license information: the library is actually under LGPLv3+,
   not GPLv3. There is a COPYING file with the text of the GPLv3 in
   the code base, but this license doesn't seem to be used in anything
   that is actually installed.
 - Add AUTORECONF = YES since we're now patching configure.ac.
 - Add missing dependency on zlib for the disassembler support.
 - Add a special LIBS=-lintl when enabling the disassembler support
   because binutils libraries use gettext functions, but they are not
   linked against libintl.]

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-01-02 19:10:52 +01:00

41 lines
1.2 KiB
Diff

Assume that the functionality is not present
Patch written by Holger Hans Peter Freyther, and fetched from
http://lists.gnu.org/archive/html/lightning/2014-11/msg00002.html.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
configure.ac | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 031279d..a36bed6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -184,7 +184,7 @@ elif test $cpu = x86; then
: "0" (1));
return (edx & 1 << 26) ? 0 : 1;
}
- ]])],[ac_cv_test_x86_x87=yes],[][])
+ ]])],[ac_cv_test_x86_x87=yes],[],[ac_cv_test_x86_x87=no])
elif test $cpu = arm; then
AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <stdio.h>
@@ -207,7 +207,7 @@ elif test $cpu = arm; then
#endif
return 1;
}
- ]])],[ac_cv_test_arm_arm=yes],[][])
+ ]])],[ac_cv_test_arm_arm=yes],[],[ac_cv_test_arm_arm=no])
AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <stdio.h>
int main(void) {
@@ -229,7 +229,7 @@ elif test $cpu = arm; then
#endif
return 1;
}
- ]])],[ac_cv_test_arm_swf=yes],[][])
+ ]])],[ac_cv_test_arm_swf=yes],[],[ac_cv_test_arm_swf=no])
fi
CFLAGS=$save_CFLAGS